Back to overview
Downtime

Warn - Risk of power outage

Mar 11, 2026 at 5:55am UTC
Affected services
Payment Platform
Games Panel Manager
SV01
SV02

Resolved
Mar 11, 2026 at 11:51pm UTC

Power back on

Due to current temperatures, risk of power outage still present.

Updated
Mar 11, 2026 at 11:28pm UTC

Return delayed

Sorry for the inconvenience.
Unfortunately, this is beyond our control.
Thank you for your patience.

Updated
Mar 11, 2026 at 10:53pm UTC

Power outage
Return unknown

We will give update as soon as we can

Created
Mar 11, 2026 at 5:55am UTC

Risk of power outage caused by bad weather